Supported Applications

Printer-friendly version

Below is the current level of support that the ITS staff can provide to end-users experiencing technical issues with Pace computer applications and web based systems. Software, systems, or applications that are not listed below are considered unsupported applications.  ITS will make a concerted effort to provide assistance for unsupported applications.

Pace University maintains ‘enterprise software’ license agreements, which allow staff and faculty to use licensed software for work or personal business.  To view a list of available licensed software, please visit the Licensed Software page.


  Full Support   Limited Support
Pace ITS staff will provide full support. Pace ITS staff will make a concerted effort to provide assistance, or will offer alternative resources if applicable.

Note: For all internal Pace Web-based systems, we recommend Mozilla Firefox 4.0 or higher.
All older system versions or unlisted systems are currently not supported.

Pace Web-Based Systems

Banner
Note: Banner currently supports Java 7 Update 65.

Internet Explorer 7.0 or Higher
Mozilla Firefox 3.5 or Higher

Blackboard
Note: Blackboard currently supports Java 7 Update 65.

Internet Explorer 8.0
Internet Explorer 9.0 or Higher
Mozilla Firefox 3.6 or Higher
E-Procurement Internet Explorer 7.0 or Higher
Mozilla Firefox 3.5 or Higher
Finance Self-Service  Internet Explorer 7.0 or Higher
Mozilla Firefox 8.0 or Higher

Kronos
Note: Kronos currently supports Java 7, Update 65

Internet Explorer 6.0 or Higher
Mozilla Firefox 2.0 or Higher
LibertyNet Internet Explorer 8.0 or Higher
Pace University Homepage Internet Explorer 9.0 or Higher,
Note: Limited support available for IE 10
Mozilla Firefox 4.0 or Higher
Performance Management and Development Program (PMDP) Internet Explorer 9.0 and 10.0
Mozilla Firefox 4.0 or Higher
Outlook Web App (OWA) Internet Explorer 7.0 or Higher
Mozilla Firefox 3.0 or Higher
People Admin Internet Explorer 7.0 or Higher
Portal Internet Explorer 8.0 or Higher
Mozilla Firefox 4.0 or Higher


Note: As of April 8th, 2014, Microsoft ended support of its Windows XP and Office 2003 products. 
As a result, ITS no longer supports these applications.

Operating Systems
Windows 8/RT
Note: Windows 8 (including Windows RT) is not fully supported for Pace systems, at this time we are testing the OS to be sure that all Pace systems will work correctly within it. Please check back for updates.
Windows 7
Windows Vista
 Mac OS 10.5 or Higher

 

Web Browsers
Internet Explorer
Note: Please refer to the Pace Web-Based Systems table above for specific versions supported by each system
Mozilla Firefox
Note: Please refer to the Pace Web-Based Systems table above for specific versions supported by each system

 

Software for Educational/Office Use
Microsoft Office 2007 or Higher
Microsoft Lync
Cisco AnyConnect
Acrobat Reader 9 or Higher
Java 7, Update 65
Pharos
Core FTP

 
Note: ITS does not recommend or support using IMAP or POP clients
because they do not fully incorporate all the features of Exchange.

Email Client
Microsoft Outlook 2007 or Higher (2013 recommended)
Microsoft Outlook 2011 for Mac
Apple Mail version 3 or Higher

 

Mobile Client on Exchange Email
Windows Phone 7/8 devices
Apple iOS Devices
Google Android Devices
Blackberry Devices

 

Virtual Private Networking
Cisco AnyConnect VPN Supported on:
  • Mac OS X 10.6 (Snow Leopard)
  • Mac OS X 10.7 (Lion)
  • Mac OS X 10.8 (Mountain Lion)
  • Windows Vista (SP2)
  • Windows 7 (SP1)
Limited or No Support on:
  • Windows 8 –  Limited support
  • Windows RT – No support
  • Mac OS X 10.5 – No Support

 

Virus Protection
System Center 2012 Endpoint Protection
Microsoft Forefront

 

Wireless Network
PACE-OPEN/PACE-WIRELESS (Running on OS systems: XP, Vista, 7, Mac OS 10.6 and higher, Apple iOS 6 and higher, Android OS 4.1 and higher)
Supported Java Versions: Java Version 7, Update 56 (or higher) must be installed
Supported Web Browsers: Internet Explorer 9.0 or Higher & Mozilla Firefox 19.0 or Higher

Last Updated Date:  5/15/2014