main navigation
my pace
Supported Software

Below is the current level of support that the ITS staff can provide to end-users experiencing technical issues with Pace computer applications and web based systems. Software, systems, or applications that are not listed below are considered unsupported applications.  ITS will make a concerted effort to provide assistance for unsupported applications.

Pace University maintains ‘enterprise software’ license agreements, which allow staff and faculty to use licensed software for work or personal business.  To view a list of available licensed software, please visit the Licensed Software page.


  Full Support   Limited Support
Pace ITS staff will provide full support. Pace ITS staff will make a concerted effort to provide assistance, or will offer alternative resources if applicable.

Note: For all internal Pace Web-based systems, we recommend Mozilla Firefox. Please refer to the table below for more information on all compatible versions. All older and unlisted web browser versions are not currently supported.

Pace Web-Based Systems
Appserv Applications Mozilla Firefox 39 or Higher
Internet Explorer 11.0 or Higher

Banner
Note: Banner currently supports latest version of Java 8.

Mozilla Firefox 39 or Higher
Internet Explorer 11.0 or Higher
BI – Reporting Pyramid Analytics Mozilla Firefox 39 or Higher
Internet Explorer 11.0 or Higher

Blackboard
Note: Blackboard currently supports latest version of Java 8.

Mozilla Firefox 39 or Higher
Internet Explorer 11.0 or Higher
E-Procurement Mozilla Firefox 39 or Higher
Internet Explorer 11.0 or Higher
Finance Self-Service Mozilla Firefox 39 or Higher
Internet Explorer 11.0 or Higher

Kronos
Note: Kronos currently supports latest version of Java 8.

Mozilla Firefox 39 or Higher
Internet Explorer 11.0 or Higher
Pace University Homepage Mozilla Firefox 39 or Higher
Internet Explorer 11.0 or Higher

Performance Management and Development Program (PMDP)
Note: Works in compatibility mode.

 

Mozilla Firefox 39 or Higher
Internet Explorer 11.0 or Higher
Outlook Web App (OWA) Mozilla Firefox 39 or Higher
Internet Explorer 11.0 or Higher
People Admin Internet Explorer 11.0 or Higher
Portal Mozilla Firefox 39 or Higher
Internet Explorer 11.0 or Higher
Shibboleth Mozilla Firefox 39 or Higher
Internet Explorer 11.0 or Higher


Note: As of April 8th, 2014, Microsoft ended support of its Windows XP and Office 2003 products. 
As a result, ITS no longer supports these applications.

Operating Systems
Windows 10/8.1/RT
Note: Windows 10 and 8.1 (including Windows RT) is not fully supported for Pace systems, at this time we are testing the OS to be sure that all Pace systems will work correctly within it. Please check back for updates.
Windows 7
 Mac OS 10.5 or Higher
Note: There is a known wireless connectivity issue with Mac OS X 10.10 (Yosemite)… read more here
At this time, OS X 10.10 Yosemite is not fully-supported for Pace systems.

 

Web Browsers
Mozilla Firefox
Note: Please refer to the Pace Web-Based Systems table above for specific versions supported by each system
Internet Explorer
Note: Please refer to the Pace Web-Based Systems table above for specific versions supported by each system.

 

Software for Educational/Office Use
Microsoft Office 2010 or Higher
Microsoft Skype for Business
Cisco AnyConnect
Acrobat Reader 9 or Higher
Java 8
Pharos
Core FTP

 
Note: ITS does not recommend or support using IMAP or POP clients because they do not fully incorporate all the features of Exchange.

Email Client
Microsoft Outlook 2010 or Higher (2013 recommended)
Microsoft Outlook 2011 for Mac
Apple Mail version 3 or Higher

 

Mobile Client on Exchange Email
Windows Phone 7/8 devices
Apple iOS Devices
Google Android Devices
Blackberry 10 Devices

Virtual Private Networking
Cisco AnyConnect VPN Supported on:
  • Mac OS X 10.6 (Snow Leopard)
  • Mac OS X 10.7 (Lion)
  • Mac OS X 10.8 (Mountain Lion)
  • Windows Vista (SP2)
  • Windows 7 (SP1)
    Note: There is a known issue affecting Windows 7 and Internet Explorer 11; when trying to connect via Cisco AnyConnect VPN, users get a “Failed to initialize connection subsystem” error – read more here.  This issue appears to have been caused by Windows Update KB3034682. Windows 8.1 was also affected by a similar Windows update KB3023607. 

Limited or No Support on:
  • Windows 10 - Limited Support
  • Windows 8 & 8.1 –  Limited Support
  • Windows RT – No Support
  • Mac OS X 10.5 – No Support

 

Virus Protection
Microsoft Security Essentials

 

Wireless Network
PACE-OPEN/PACE-WIRELESS (Running on OS systems: Windows 7, Windows 8.1, Mac OS 10.6 and higher, Apple iOS 6 and higher, Android OS 4.1 and higher)
Supported Java Versions: Java Version 7, Update 56 (or higher) must be installed
Supported Web Browsers: Internet Explorer 11.0 or higher

Last Updated Date:  04/06/2016